Windows VM Performance Degradation
Incident Report for Simply Cloud Status Page
Resolved
We have corrected the issue with the faulty nodes and performance should now have returned to normal for all customers.
Posted Aug 16, 2019 - 13:21 BST
Investigating
We are currently experiencing compute node failures for our Windows VMs (Cloud and standard packages). There may be performance degradation as customer VMs are re-homed on working nodes. We are working to restore service as quickly as possible. - The Simply Cloud team
Posted Aug 16, 2019 - 11:12 BST
This incident affected: Cloud Servers and Virtual Servers (VPS).