Windows Cloud Outage
Incident Report for Simply Cloud Status Page
Resolved
All VMs should now be back online. If your VM is still unreachable please reply to this ticket and we will investigate further. Apologies again for any inconvenience caused.

The Simply Cloud Team
Posted Oct 09, 2020 - 18:51 BST
Identified
The issue affecting the Windows cluster has been identified and engineers are working to implement a fix on all nodes. There is no ETA for a complete resolution at present. Further updates will follow shortly.
Posted Oct 09, 2020 - 17:32 BST
Investigating
We are aware of an issue affecting a subset of Windows Cloud VM customers at the moment. Engineers are working on the issue as a matter of urgency and hope to resolve the issue soon.
Posted Oct 09, 2020 - 16:18 BST
This incident affected: Cloud Servers and Virtual Servers (VPS).