DNS resolver issue
Incident Report for Simply Cloud Status Page
Resolved
The faulty resolver has been fixed and returned to service.
Posted 7 days ago. Sep 09, 2019 - 10:01 BST
Investigating
One of our DNS resolvers, 78.40.32.140 is currently not responding properly to requests and is under investigation.

Customers should not experience any service interruption so long as they have a second resolver (130.193.93.101) configured.
Posted 7 days ago. Sep 09, 2019 - 09:17 BST
This incident affected: Dedicated Servers, Cloud Servers, and Virtual Servers (VPS).